Gradescope Service Incident - March 6, 2025

Incident Report for Gradescope

Resolved

We’ve fixed it!

Due to an unexpected service incident, users may have been unable to build Code Autograders, encountered failing Code Autograders, and experienced issues with running the Code Autograder with certain submissions, in Gradescope.com today.

All other assignment types and instances of Gradescope were unaffected. Users accessing the service via an integration, may have also been affected. Users may need to re-run their Code Autograders to resolve affected submissions and assignments.

We are pleased to advise that service has been restored.

We encountered a disruption between the following times:

PST: March 6th, 03:00 - March 6th, 07:00
GMT: March 6th, 11:00 - March 6th, 15:00
AEDT: March 6th, 22:00 - March 7th, 02:00

We regret any inconvenience this may have caused if you were impacted by today’s disruption.
Posted Mar 06, 2025 - 07:23 PST

Investigating

We’ve run into some issues.

Gradescope.com is currently experiencing an unexpected service incident.

During this time, you may find that users are unable to build Code Autograders in Gradescope, Code Autograders are failing to start, or experience issues with running the Code Autograder with certain submissions. All other assignment types and instances of Gradescope are unaffected. Users accessing the service via an integration, may also be affected.

We invite you to track the progress of this disruption while we work to bring the service back to optimum health.
Posted Mar 06, 2025 - 06:15 PST
This incident affected: Gradescope Core Functionality (Gradescope.com) and Code Autograder.